Back to overview
Downtime
Summit Website, Summit Talks App, and 3 other services are down
Apr 22, 2026 at 5:35am UTC
Affected services
Summit Website
Summit Talks App
The BOSS / Student Registration
Summit Giving App
Summit U App
Resolved
Apr 22, 2026 at 5:40am UTC
Summit U App recovered.
Affected services
Updated
Apr 22, 2026 at 5:39am UTC
Summit Website, Summit Talks App, The BOSS / Student Registration, and 1 other resource recovered.
Affected services
Created
Apr 22, 2026 at 5:35am UTC
Summit Website, Summit Talks App, The BOSS / Student Registration, and 2 other resources went down.
Affected services